Discussion:
Problems Installing Passenger Enterprise Version 3.0.18 on Mountain Lion
LightBe Corp
2012-12-13 16:26:31 UTC
Permalink
I just purchased a one year license a few minutes ago after upgrading from
Lion to Mountain Lion. I downloaded and installed the 3.0.18 gem. I then
installed the license key by copying the downloaded file into /etc as
stated. Afterwards I attempted to install the Apache version of 3.0.18 by
doing the following terminal command:

sudo passenger-install-apache2-module

The following displayed in the terminal:

*Checking for required software...*
*
*
* * GNU C++ compiler... found at /usr/bin/g++*
* * Curl development headers with SSL support... found*
* * OpenSSL development headers... found*
* * Zlib development headers... found*
* * Ruby development headers... found*
* * OpenSSL support for Ruby... found*
* * RubyGems... found*
*Your RVM wrapper scripts are too old. Please update them first by running
'rvm get head && rvm reload && rvm repair all'.*

I executed the suggested commands two or three times but got the same
error. I did a web search and someone on Stack Overflow suggested that you
should do the first two commands mentioned in the Passenger output and then
do rvm get stable. I still get the error.

I thought I would try rvmsudo passenger-install-apache2-module. I believe
I had used it before. The following errors were displayed:

*/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:247:in
`to_specs': Could not find passenger-enterprise-server (>= 0) amongst
[actionmailer-3.2.9, actionpack-3.2.9, activemodel-3.2.9,
activerecord-3.2.9, activeresource-3.2.9, activesupport-3.2.9,
annotate-2.4.1.beta1, arel-3.0.2, builder-3.0.4, bundler-1.2.3,
capybara-1.1.2, childprocess-0.3.6, coderay-1.0.8, coffee-rails-3.2.2,
coffee-script-2.2.0, coffee-script-source-1.4.0, commonjs-0.2.6,
cucumber-1.2.1, cucumber-rails-1.2.1, daemons-1.1.9, diff-lcs-1.1.3,
erubis-2.7.0, eventmachine-1.0.0, execjs-1.4.0, ffi-1.2.0, gherkin-2.11.5,
growl-1.0.3, guard-1.5.4, guard-rspec-1.2.1, guard-spork-1.2.0, hike-1.2.1,
i18n-0.6.1, journey-1.0.4, jquery-rails-2.0.2, json-1.7.5, less-2.2.2,
less-rails-2.2.6, libv8-3.3.10.4-x86_64-darwin-12, libwebsocket-0.1.6.1,
listen-0.6.0, lumberjack-1.0.2, mail-2.4.4, metamagic-2.0.4,
method_source-0.8.1, mime-types-1.19, multi_json-1.5.0, multi_json-1.3.7,
nokogiri-1.5.5, polyglot-0.3.3, pry-0.9.10, rack-1.4.1, rack-cache-1.2,
rack-ssl-1.3.2, rack-test-0.6.2, rails-3.2.9, railties-3.2.9, rake-10.0.3,
rake-10.0.2, rb-fsevent-0.9.2, rdoc-3.12, rspec-2.11.0, rspec-core-2.11.1,
rspec-expectations-2.11.3, rspec-mocks-2.11.3, rspec-rails-2.11.0,
rubygems-bundler-1.1.0, rubyzip-0.9.9, rvm-1.11.3.5, sass-3.2.3,
sass-rails-3.2.5, selenium-webdriver-2.26.0, slop-3.3.3, spork-0.9.2,
sprockets-2.2.2, sprockets-2.2.1, sqlite3-1.3.6,
sys-proctable-0.9.2-universal-darwin, therubyracer-0.10.2, thin-1.5.0,
thor-0.16.0, tilt-1.3.3, treetop-1.4.12, twitter-bootstrap-rails-2.1.2,
tzinfo-0.3.35, uglifier-1.2.3, websocket-1.0.4, xpath-0.1.4]
(Gem::LoadError)*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:256:in
`to_spec'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems.rb:1231:in
`gem'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/bin/passenger-install-apache2-module:22:in
`<main>'*

I cannot find anything in the Passenger software for this problem. What
version of RVM should I use to get this working? From what I have read I
should not be seeing the error at all with newer versions of RVM. I have
three websites that I need to get working immediately. I cannot do
anything until this is resolved. I have not used RVM for much other than
installing Ruby at this point. Any help will be appreciated. Thanks!
--
Please visit http://rvm.io/ for documentation on rvm.
Please visit https://www.pivotaltracker.com/projects/26822 to see what is being worked on currently.

You received this message because you are subscribed to the Google
Groups "rvm (Ruby Version Manager)" group.
To post to this group, send email to rubyversionmanager-/***@public.gmane.org
To unsubscribe from this group, send email to
rubyversionmanager+unsubscribe-/***@public.gmane.org
For more options, visit this group at
http://groups.google.com/group/rubyversionmanager?hl=en
mpapis
2012-12-13 16:32:14 UTC
Permalink
you do not use sudo with RVM, make sure to use rvmsudo
Post by LightBe Corp
I just purchased a one year license a few minutes ago after upgrading from
Lion to Mountain Lion. I downloaded and installed the 3.0.18 gem. I then
installed the license key by copying the downloaded file into /etc as
stated. Afterwards I attempted to install the Apache version of 3.0.18 by
sudo passenger-install-apache2-module
*Checking for required software...*
*
*
* * GNU C++ compiler... found at /usr/bin/g++*
* * Curl development headers with SSL support... found*
* * OpenSSL development headers... found*
* * Zlib development headers... found*
* * Ruby development headers... found*
* * OpenSSL support for Ruby... found*
* * RubyGems... found*
*Your RVM wrapper scripts are too old. Please update them first by
running 'rvm get head && rvm reload && rvm repair all'.*
I executed the suggested commands two or three times but got the same
error. I did a web search and someone on Stack Overflow suggested that you
should do the first two commands mentioned in the Passenger output and then
do rvm get stable. I still get the error.
I thought I would try rvmsudo passenger-install-apache2-module. I believe
*/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:247:in
`to_specs': Could not find passenger-enterprise-server (>= 0) amongst
[actionmailer-3.2.9, actionpack-3.2.9, activemodel-3.2.9,
activerecord-3.2.9, activeresource-3.2.9, activesupport-3.2.9,
annotate-2.4.1.beta1, arel-3.0.2, builder-3.0.4, bundler-1.2.3,
capybara-1.1.2, childprocess-0.3.6, coderay-1.0.8, coffee-rails-3.2.2,
coffee-script-2.2.0, coffee-script-source-1.4.0, commonjs-0.2.6,
cucumber-1.2.1, cucumber-rails-1.2.1, daemons-1.1.9, diff-lcs-1.1.3,
erubis-2.7.0, eventmachine-1.0.0, execjs-1.4.0, ffi-1.2.0, gherkin-2.11.5,
growl-1.0.3, guard-1.5.4, guard-rspec-1.2.1, guard-spork-1.2.0, hike-1.2.1,
i18n-0.6.1, journey-1.0.4, jquery-rails-2.0.2, json-1.7.5, less-2.2.2,
less-rails-2.2.6, libv8-3.3.10.4-x86_64-darwin-12, libwebsocket-0.1.6.1,
listen-0.6.0, lumberjack-1.0.2, mail-2.4.4, metamagic-2.0.4,
method_source-0.8.1, mime-types-1.19, multi_json-1.5.0, multi_json-1.3.7,
nokogiri-1.5.5, polyglot-0.3.3, pry-0.9.10, rack-1.4.1, rack-cache-1.2,
rack-ssl-1.3.2, rack-test-0.6.2, rails-3.2.9, railties-3.2.9, rake-10.0.3,
rake-10.0.2, rb-fsevent-0.9.2, rdoc-3.12, rspec-2.11.0, rspec-core-2.11.1,
rspec-expectations-2.11.3, rspec-mocks-2.11.3, rspec-rails-2.11.0,
rubygems-bundler-1.1.0, rubyzip-0.9.9, rvm-1.11.3.5, sass-3.2.3,
sass-rails-3.2.5, selenium-webdriver-2.26.0, slop-3.3.3, spork-0.9.2,
sprockets-2.2.2, sprockets-2.2.1, sqlite3-1.3.6,
sys-proctable-0.9.2-universal-darwin, therubyracer-0.10.2, thin-1.5.0,
thor-0.16.0, tilt-1.3.3, treetop-1.4.12, twitter-bootstrap-rails-2.1.2,
tzinfo-0.3.35, uglifier-1.2.3, websocket-1.0.4, xpath-0.1.4]
(Gem::LoadError)*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:256:in
`to_spec'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems.rb:1231:in
`gem'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/bin/passenger-install-apache2-module:22:in
`<main>'*
I cannot find anything in the Passenger software for this problem. What
version of RVM should I use to get this working? From what I have read I
should not be seeing the error at all with newer versions of RVM. I have
three websites that I need to get working immediately. I cannot do
anything until this is resolved. I have not used RVM for much other than
installing Ruby at this point. Any help will be appreciated. Thanks!
--
Please visit http://rvm.io/ for documentation on rvm.
Please visit https://www.pivotaltracker.com/projects/26822 to see what is being worked on currently.

You received this message because you are subscribed to the Google
Groups "rvm (Ruby Version Manager)" group.
To post to this group, send email to rubyversionmanager-/***@public.gmane.org
To unsubscribe from this group, send email to
rubyversionmanager+unsubscribe-/***@public.gmane.org
For more options, visit this group at
http://groups.google.com/group/rubyversionmanager?hl=en
LightBe Corp
2012-12-13 16:41:12 UTC
Permalink
Post by mpapis
you do not use sudo with RVM, make sure to use rvmsudo
Post by LightBe Corp
I just purchased a one year license a few minutes ago after upgrading
from Lion to Mountain Lion. I downloaded and installed the 3.0.18 gem. I
then installed the license key by copying the downloaded file into /etc as
stated. Afterwards I attempted to install the Apache version of 3.0.18 by
sudo passenger-install-apache2-module
*Checking for required software...*
*
*
* * GNU C++ compiler... found at /usr/bin/g++*
* * Curl development headers with SSL support... found*
* * OpenSSL development headers... found*
* * Zlib development headers... found*
* * Ruby development headers... found*
* * OpenSSL support for Ruby... found*
* * RubyGems... found*
*Your RVM wrapper scripts are too old. Please update them first by
running 'rvm get head && rvm reload && rvm repair all'.*
I executed the suggested commands two or three times but got the same
error. I did a web search and someone on Stack Overflow suggested that you
should do the first two commands mentioned in the Passenger output and then
do rvm get stable. I still get the error.
I thought I would try rvmsudo passenger-install-apache2-module. I
*/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:247:in
`to_specs': Could not find passenger-enterprise-server (>= 0) amongst
[actionmailer-3.2.9, actionpack-3.2.9, activemodel-3.2.9,
activerecord-3.2.9, activeresource-3.2.9, activesupport-3.2.9,
annotate-2.4.1.beta1, arel-3.0.2, builder-3.0.4, bundler-1.2.3,
capybara-1.1.2, childprocess-0.3.6, coderay-1.0.8, coffee-rails-3.2.2,
coffee-script-2.2.0, coffee-script-source-1.4.0, commonjs-0.2.6,
cucumber-1.2.1, cucumber-rails-1.2.1, daemons-1.1.9, diff-lcs-1.1.3,
erubis-2.7.0, eventmachine-1.0.0, execjs-1.4.0, ffi-1.2.0, gherkin-2.11.5,
growl-1.0.3, guard-1.5.4, guard-rspec-1.2.1, guard-spork-1.2.0, hike-1.2.1,
i18n-0.6.1, journey-1.0.4, jquery-rails-2.0.2, json-1.7.5, less-2.2.2,
less-rails-2.2.6, libv8-3.3.10.4-x86_64-darwin-12, libwebsocket-0.1.6.1,
listen-0.6.0, lumberjack-1.0.2, mail-2.4.4, metamagic-2.0.4,
method_source-0.8.1, mime-types-1.19, multi_json-1.5.0, multi_json-1.3.7,
nokogiri-1.5.5, polyglot-0.3.3, pry-0.9.10, rack-1.4.1, rack-cache-1.2,
rack-ssl-1.3.2, rack-test-0.6.2, rails-3.2.9, railties-3.2.9, rake-10.0.3,
rake-10.0.2, rb-fsevent-0.9.2, rdoc-3.12, rspec-2.11.0, rspec-core-2.11.1,
rspec-expectations-2.11.3, rspec-mocks-2.11.3, rspec-rails-2.11.0,
rubygems-bundler-1.1.0, rubyzip-0.9.9, rvm-1.11.3.5, sass-3.2.3,
sass-rails-3.2.5, selenium-webdriver-2.26.0, slop-3.3.3, spork-0.9.2,
sprockets-2.2.2, sprockets-2.2.1, sqlite3-1.3.6,
sys-proctable-0.9.2-universal-darwin, therubyracer-0.10.2, thin-1.5.0,
thor-0.16.0, tilt-1.3.3, treetop-1.4.12, twitter-bootstrap-rails-2.1.2,
tzinfo-0.3.35, uglifier-1.2.3, websocket-1.0.4, xpath-0.1.4]
(Gem::LoadError)*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:256:in
`to_spec'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems.rb:1231:in
`gem'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/bin/passenger-install-apache2-module:22:in
`<main>'*
I cannot find anything in the Passenger software for this problem. What
version of RVM should I use to get this working? From what I have read I
should not be seeing the error at all with newer versions of RVM. I have
three websites that I need to get working immediately. I cannot do
anything until this is resolved. I have not used RVM for much other than
installing Ruby at this point. Any help will be appreciated. Thanks!
--
Please visit http://rvm.io/ for documentation on rvm.
Please visit https://www.pivotaltracker.com/projects/26822 to see what is being worked on currently.

You received this message because you are subscribed to the Google
Groups "rvm (Ruby Version Manager)" group.
To post to this group, send email to rubyversionmanager-/***@public.gmane.org
To unsubscribe from this group, send email to
rubyversionmanager+unsubscribe-/***@public.gmane.org
For more options, visit this group at
http://groups.google.com/group/rubyversionmanager?hl=en
LightBe Corp
2012-12-13 16:41:26 UTC
Permalink
The last half of my post shows the error I got when I tried to use rvmsudo.
The information starts with the sentence right before the second block of
bold text which is the error.
Post by mpapis
you do not use sudo with RVM, make sure to use rvmsudo
Post by LightBe Corp
I just purchased a one year license a few minutes ago after upgrading
from Lion to Mountain Lion. I downloaded and installed the 3.0.18 gem. I
then installed the license key by copying the downloaded file into /etc as
stated. Afterwards I attempted to install the Apache version of 3.0.18 by
sudo passenger-install-apache2-module
*Checking for required software...*
*
*
* * GNU C++ compiler... found at /usr/bin/g++*
* * Curl development headers with SSL support... found*
* * OpenSSL development headers... found*
* * Zlib development headers... found*
* * Ruby development headers... found*
* * OpenSSL support for Ruby... found*
* * RubyGems... found*
*Your RVM wrapper scripts are too old. Please update them first by
running 'rvm get head && rvm reload && rvm repair all'.*
I executed the suggested commands two or three times but got the same
error. I did a web search and someone on Stack Overflow suggested that you
should do the first two commands mentioned in the Passenger output and then
do rvm get stable. I still get the error.
I thought I would try rvmsudo passenger-install-apache2-module. I
*/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:247:in
`to_specs': Could not find passenger-enterprise-server (>= 0) amongst
[actionmailer-3.2.9, actionpack-3.2.9, activemodel-3.2.9,
activerecord-3.2.9, activeresource-3.2.9, activesupport-3.2.9,
annotate-2.4.1.beta1, arel-3.0.2, builder-3.0.4, bundler-1.2.3,
capybara-1.1.2, childprocess-0.3.6, coderay-1.0.8, coffee-rails-3.2.2,
coffee-script-2.2.0, coffee-script-source-1.4.0, commonjs-0.2.6,
cucumber-1.2.1, cucumber-rails-1.2.1, daemons-1.1.9, diff-lcs-1.1.3,
erubis-2.7.0, eventmachine-1.0.0, execjs-1.4.0, ffi-1.2.0, gherkin-2.11.5,
growl-1.0.3, guard-1.5.4, guard-rspec-1.2.1, guard-spork-1.2.0, hike-1.2.1,
i18n-0.6.1, journey-1.0.4, jquery-rails-2.0.2, json-1.7.5, less-2.2.2,
less-rails-2.2.6, libv8-3.3.10.4-x86_64-darwin-12, libwebsocket-0.1.6.1,
listen-0.6.0, lumberjack-1.0.2, mail-2.4.4, metamagic-2.0.4,
method_source-0.8.1, mime-types-1.19, multi_json-1.5.0, multi_json-1.3.7,
nokogiri-1.5.5, polyglot-0.3.3, pry-0.9.10, rack-1.4.1, rack-cache-1.2,
rack-ssl-1.3.2, rack-test-0.6.2, rails-3.2.9, railties-3.2.9, rake-10.0.3,
rake-10.0.2, rb-fsevent-0.9.2, rdoc-3.12, rspec-2.11.0, rspec-core-2.11.1,
rspec-expectations-2.11.3, rspec-mocks-2.11.3, rspec-rails-2.11.0,
rubygems-bundler-1.1.0, rubyzip-0.9.9, rvm-1.11.3.5, sass-3.2.3,
sass-rails-3.2.5, selenium-webdriver-2.26.0, slop-3.3.3, spork-0.9.2,
sprockets-2.2.2, sprockets-2.2.1, sqlite3-1.3.6,
sys-proctable-0.9.2-universal-darwin, therubyracer-0.10.2, thin-1.5.0,
thor-0.16.0, tilt-1.3.3, treetop-1.4.12, twitter-bootstrap-rails-2.1.2,
tzinfo-0.3.35, uglifier-1.2.3, websocket-1.0.4, xpath-0.1.4]
(Gem::LoadError)*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:256:in
`to_spec'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems.rb:1231:in
`gem'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/bin/passenger-install-apache2-module:22:in
`<main>'*
I cannot find anything in the Passenger software for this problem. What
version of RVM should I use to get this working? From what I have read I
should not be seeing the error at all with newer versions of RVM. I have
three websites that I need to get working immediately. I cannot do
anything until this is resolved. I have not used RVM for much other than
installing Ruby at this point. Any help will be appreciated. Thanks!
--
Please visit http://rvm.io/ for documentation on rvm.
Please visit https://www.pivotaltracker.com/projects/26822 to see what is being worked on currently.

You received this message because you are subscribed to the Google
Groups "rvm (Ruby Version Manager)" group.
To post to this group, send email to rubyversionmanager-/***@public.gmane.org
To unsubscribe from this group, send email to
rubyversionmanager+unsubscribe-/***@public.gmane.org
For more options, visit this group at
http://groups.google.com/group/rubyversionmanager?hl=en
mpapis
2012-12-13 17:41:09 UTC
Permalink
sorry i missed it (it's know fact that to long text is not read at all -
this is why I try to cut the rvm texts)

as for the error how did you install *passenger-enterprise-server* - what
are the changes you did in /etc ?
Post by LightBe Corp
The last half of my post shows the error I got when I tried to use
rvmsudo. The information starts with the sentence right before the second
block of bold text which is the error.
Post by mpapis
you do not use sudo with RVM, make sure to use rvmsudo
Post by LightBe Corp
I just purchased a one year license a few minutes ago after upgrading
from Lion to Mountain Lion. I downloaded and installed the 3.0.18 gem. I
then installed the license key by copying the downloaded file into /etc as
stated. Afterwards I attempted to install the Apache version of 3.0.18 by
sudo passenger-install-apache2-module
*Checking for required software...*
*
*
* * GNU C++ compiler... found at /usr/bin/g++*
* * Curl development headers with SSL support... found*
* * OpenSSL development headers... found*
* * Zlib development headers... found*
* * Ruby development headers... found*
* * OpenSSL support for Ruby... found*
* * RubyGems... found*
*Your RVM wrapper scripts are too old. Please update them first by
running 'rvm get head && rvm reload && rvm repair all'.*
I executed the suggested commands two or three times but got the same
error. I did a web search and someone on Stack Overflow suggested that you
should do the first two commands mentioned in the Passenger output and then
do rvm get stable. I still get the error.
I thought I would try rvmsudo passenger-install-apache2-module. I
*/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:247:in
`to_specs': Could not find passenger-enterprise-server (>= 0) amongst
[actionmailer-3.2.9, actionpack-3.2.9, activemodel-3.2.9,
activerecord-3.2.9, activeresource-3.2.9, activesupport-3.2.9,
annotate-2.4.1.beta1, arel-3.0.2, builder-3.0.4, bundler-1.2.3,
capybara-1.1.2, childprocess-0.3.6, coderay-1.0.8, coffee-rails-3.2.2,
coffee-script-2.2.0, coffee-script-source-1.4.0, commonjs-0.2.6,
cucumber-1.2.1, cucumber-rails-1.2.1, daemons-1.1.9, diff-lcs-1.1.3,
erubis-2.7.0, eventmachine-1.0.0, execjs-1.4.0, ffi-1.2.0, gherkin-2.11.5,
growl-1.0.3, guard-1.5.4, guard-rspec-1.2.1, guard-spork-1.2.0, hike-1.2.1,
i18n-0.6.1, journey-1.0.4, jquery-rails-2.0.2, json-1.7.5, less-2.2.2,
less-rails-2.2.6, libv8-3.3.10.4-x86_64-darwin-12, libwebsocket-0.1.6.1,
listen-0.6.0, lumberjack-1.0.2, mail-2.4.4, metamagic-2.0.4,
method_source-0.8.1, mime-types-1.19, multi_json-1.5.0, multi_json-1.3.7,
nokogiri-1.5.5, polyglot-0.3.3, pry-0.9.10, rack-1.4.1, rack-cache-1.2,
rack-ssl-1.3.2, rack-test-0.6.2, rails-3.2.9, railties-3.2.9, rake-10.0.3,
rake-10.0.2, rb-fsevent-0.9.2, rdoc-3.12, rspec-2.11.0, rspec-core-2.11.1,
rspec-expectations-2.11.3, rspec-mocks-2.11.3, rspec-rails-2.11.0,
rubygems-bundler-1.1.0, rubyzip-0.9.9, rvm-1.11.3.5, sass-3.2.3,
sass-rails-3.2.5, selenium-webdriver-2.26.0, slop-3.3.3, spork-0.9.2,
sprockets-2.2.2, sprockets-2.2.1, sqlite3-1.3.6,
sys-proctable-0.9.2-universal-darwin, therubyracer-0.10.2, thin-1.5.0,
thor-0.16.0, tilt-1.3.3, treetop-1.4.12, twitter-bootstrap-rails-2.1.2,
tzinfo-0.3.35, uglifier-1.2.3, websocket-1.0.4, xpath-0.1.4]
(Gem::LoadError)*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:256:in
`to_spec'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems.rb:1231:in
`gem'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/bin/passenger-install-apache2-module:22:in
`<main>'*
I cannot find anything in the Passenger software for this problem. What
version of RVM should I use to get this working? From what I have read I
should not be seeing the error at all with newer versions of RVM. I have
three websites that I need to get working immediately. I cannot do
anything until this is resolved. I have not used RVM for much other than
installing Ruby at this point. Any help will be appreciated. Thanks!
--
Please visit http://rvm.io/ for documentation on rvm.
Please visit https://www.pivotaltracker.com/projects/26822 to see what is being worked on currently.

You received this message because you are subscribed to the Google
Groups "rvm (Ruby Version Manager)" group.
To post to this group, send email to rubyversionmanager-/***@public.gmane.org
To unsubscribe from this group, send email to
rubyversionmanager+unsubscribe-/***@public.gmane.org
For more options, visit this group at
http://groups.google.com/group/rubyversionmanager?hl=en
LightBe Corp
2012-12-13 17:51:54 UTC
Permalink
I downloaded and installed the 3.0.18 gem from www.phusionpassenger.com. I
copied the license key passenger-enterprise-license file into /etc. I
assume that is what they meant by installing the license key in to /etc as
stated on the website. Then I did the
sudo passenger-install-apache2-module command.

I mean no harm but the first few sentences tell you what I did to initially
install this :)
Post by mpapis
sorry i missed it (it's know fact that to long text is not read at all -
this is why I try to cut the rvm texts)
as for the error how did you install *passenger-enterprise-server* - what
are the changes you did in /etc ?
Post by LightBe Corp
The last half of my post shows the error I got when I tried to use
rvmsudo. The information starts with the sentence right before the second
block of bold text which is the error.
Post by mpapis
you do not use sudo with RVM, make sure to use rvmsudo
Post by LightBe Corp
I just purchased a one year license a few minutes ago after upgrading
from Lion to Mountain Lion. I downloaded and installed the 3.0.18 gem. I
then installed the license key by copying the downloaded file into /etc as
stated. Afterwards I attempted to install the Apache version of 3.0.18 by
sudo passenger-install-apache2-module
*Checking for required software...*
*
*
* * GNU C++ compiler... found at /usr/bin/g++*
* * Curl development headers with SSL support... found*
* * OpenSSL development headers... found*
* * Zlib development headers... found*
* * Ruby development headers... found*
* * OpenSSL support for Ruby... found*
* * RubyGems... found*
*Your RVM wrapper scripts are too old. Please update them first by
running 'rvm get head && rvm reload && rvm repair all'.*
I executed the suggested commands two or three times but got the same
error. I did a web search and someone on Stack Overflow suggested that you
should do the first two commands mentioned in the Passenger output and then
do rvm get stable. I still get the error.
I thought I would try rvmsudo passenger-install-apache2-module. I
*/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:247:in
`to_specs': Could not find passenger-enterprise-server (>= 0) amongst
[actionmailer-3.2.9, actionpack-3.2.9, activemodel-3.2.9,
activerecord-3.2.9, activeresource-3.2.9, activesupport-3.2.9,
annotate-2.4.1.beta1, arel-3.0.2, builder-3.0.4, bundler-1.2.3,
capybara-1.1.2, childprocess-0.3.6, coderay-1.0.8, coffee-rails-3.2.2,
coffee-script-2.2.0, coffee-script-source-1.4.0, commonjs-0.2.6,
cucumber-1.2.1, cucumber-rails-1.2.1, daemons-1.1.9, diff-lcs-1.1.3,
erubis-2.7.0, eventmachine-1.0.0, execjs-1.4.0, ffi-1.2.0, gherkin-2.11.5,
growl-1.0.3, guard-1.5.4, guard-rspec-1.2.1, guard-spork-1.2.0, hike-1.2.1,
i18n-0.6.1, journey-1.0.4, jquery-rails-2.0.2, json-1.7.5, less-2.2.2,
less-rails-2.2.6, libv8-3.3.10.4-x86_64-darwin-12, libwebsocket-0.1.6.1,
listen-0.6.0, lumberjack-1.0.2, mail-2.4.4, metamagic-2.0.4,
method_source-0.8.1, mime-types-1.19, multi_json-1.5.0, multi_json-1.3.7,
nokogiri-1.5.5, polyglot-0.3.3, pry-0.9.10, rack-1.4.1, rack-cache-1.2,
rack-ssl-1.3.2, rack-test-0.6.2, rails-3.2.9, railties-3.2.9, rake-10.0.3,
rake-10.0.2, rb-fsevent-0.9.2, rdoc-3.12, rspec-2.11.0, rspec-core-2.11.1,
rspec-expectations-2.11.3, rspec-mocks-2.11.3, rspec-rails-2.11.0,
rubygems-bundler-1.1.0, rubyzip-0.9.9, rvm-1.11.3.5, sass-3.2.3,
sass-rails-3.2.5, selenium-webdriver-2.26.0, slop-3.3.3, spork-0.9.2,
sprockets-2.2.2, sprockets-2.2.1, sqlite3-1.3.6,
sys-proctable-0.9.2-universal-darwin, therubyracer-0.10.2, thin-1.5.0,
thor-0.16.0, tilt-1.3.3, treetop-1.4.12, twitter-bootstrap-rails-2.1.2,
tzinfo-0.3.35, uglifier-1.2.3, websocket-1.0.4, xpath-0.1.4]
(Gem::LoadError)*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:256:in
`to_spec'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems.rb:1231:in
`gem'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/bin/passenger-install-apache2-module:22:in
`<main>'*
I cannot find anything in the Passenger software for this problem.
What version of RVM should I use to get this working? From what I have
read I should not be seeing the error at all with newer versions of RVM. I
have three websites that I need to get working immediately. I cannot do
anything until this is resolved. I have not used RVM for much other than
installing Ruby at this point. Any help will be appreciated. Thanks!
--
Please visit http://rvm.io/ for documentation on rvm.
Please visit https://www.pivotaltracker.com/projects/26822 to see what is being worked on currently.

You received this message because you are subscribed to the Google
Groups "rvm (Ruby Version Manager)" group.
To post to this group, send email to rubyversionmanager-/***@public.gmane.org
To unsubscribe from this group, send email to
rubyversionmanager+unsubscribe-/***@public.gmane.org
For more options, visit this group at
http://groups.google.com/group/rubyversionmanager?hl=en
mpapis
2012-12-13 18:35:46 UTC
Permalink
please talk to me(mpapis) here => http://webchat.freenode.net/?channels=rvm

there is a lot of small questions to ask it would be a lot faster this way
Post by LightBe Corp
I downloaded and installed the 3.0.18 gem from www.phusionpassenger.com.
I copied the license key passenger-enterprise-license file into /etc. I
assume that is what they meant by installing the license key in to /etc as
stated on the website. Then I did the
sudo passenger-install-apache2-module command.
I mean no harm but the first few sentences tell you what I did to
initially install this :)
Post by mpapis
sorry i missed it (it's know fact that to long text is not read at all -
this is why I try to cut the rvm texts)
as for the error how did you install *passenger-enterprise-server* -
what are the changes you did in /etc ?
Post by LightBe Corp
The last half of my post shows the error I got when I tried to use
rvmsudo. The information starts with the sentence right before the second
block of bold text which is the error.
Post by mpapis
you do not use sudo with RVM, make sure to use rvmsudo
Post by LightBe Corp
I just purchased a one year license a few minutes ago after upgrading
from Lion to Mountain Lion. I downloaded and installed the 3.0.18 gem. I
then installed the license key by copying the downloaded file into /etc as
stated. Afterwards I attempted to install the Apache version of 3.0.18 by
sudo passenger-install-apache2-module
*Checking for required software...*
*
*
* * GNU C++ compiler... found at /usr/bin/g++*
* * Curl development headers with SSL support... found*
* * OpenSSL development headers... found*
* * Zlib development headers... found*
* * Ruby development headers... found*
* * OpenSSL support for Ruby... found*
* * RubyGems... found*
*Your RVM wrapper scripts are too old. Please update them first by
running 'rvm get head && rvm reload && rvm repair all'.*
I executed the suggested commands two or three times but got the same
error. I did a web search and someone on Stack Overflow suggested that you
should do the first two commands mentioned in the Passenger output and then
do rvm get stable. I still get the error.
I thought I would try rvmsudo passenger-install-apache2-module. I
*/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:247:in
`to_specs': Could not find passenger-enterprise-server (>= 0) amongst
[actionmailer-3.2.9, actionpack-3.2.9, activemodel-3.2.9,
activerecord-3.2.9, activeresource-3.2.9, activesupport-3.2.9,
annotate-2.4.1.beta1, arel-3.0.2, builder-3.0.4, bundler-1.2.3,
capybara-1.1.2, childprocess-0.3.6, coderay-1.0.8, coffee-rails-3.2.2,
coffee-script-2.2.0, coffee-script-source-1.4.0, commonjs-0.2.6,
cucumber-1.2.1, cucumber-rails-1.2.1, daemons-1.1.9, diff-lcs-1.1.3,
erubis-2.7.0, eventmachine-1.0.0, execjs-1.4.0, ffi-1.2.0, gherkin-2.11.5,
growl-1.0.3, guard-1.5.4, guard-rspec-1.2.1, guard-spork-1.2.0, hike-1.2.1,
i18n-0.6.1, journey-1.0.4, jquery-rails-2.0.2, json-1.7.5, less-2.2.2,
less-rails-2.2.6, libv8-3.3.10.4-x86_64-darwin-12, libwebsocket-0.1.6.1,
listen-0.6.0, lumberjack-1.0.2, mail-2.4.4, metamagic-2.0.4,
method_source-0.8.1, mime-types-1.19, multi_json-1.5.0, multi_json-1.3.7,
nokogiri-1.5.5, polyglot-0.3.3, pry-0.9.10, rack-1.4.1, rack-cache-1.2,
rack-ssl-1.3.2, rack-test-0.6.2, rails-3.2.9, railties-3.2.9, rake-10.0.3,
rake-10.0.2, rb-fsevent-0.9.2, rdoc-3.12, rspec-2.11.0, rspec-core-2.11.1,
rspec-expectations-2.11.3, rspec-mocks-2.11.3, rspec-rails-2.11.0,
rubygems-bundler-1.1.0, rubyzip-0.9.9, rvm-1.11.3.5, sass-3.2.3,
sass-rails-3.2.5, selenium-webdriver-2.26.0, slop-3.3.3, spork-0.9.2,
sprockets-2.2.2, sprockets-2.2.1, sqlite3-1.3.6,
sys-proctable-0.9.2-universal-darwin, therubyracer-0.10.2, thin-1.5.0,
thor-0.16.0, tilt-1.3.3, treetop-1.4.12, twitter-bootstrap-rails-2.1.2,
tzinfo-0.3.35, uglifier-1.2.3, websocket-1.0.4, xpath-0.1.4]
(Gem::LoadError)*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:256:in
`to_spec'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems.rb:1231:in
`gem'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/bin/passenger-install-apache2-module:22:in
`<main>'*
I cannot find anything in the Passenger software for this problem.
What version of RVM should I use to get this working? From what I have
read I should not be seeing the error at all with newer versions of RVM. I
have three websites that I need to get working immediately. I cannot do
anything until this is resolved. I have not used RVM for much other than
installing Ruby at this point. Any help will be appreciated. Thanks!
--
Please visit http://rvm.io/ for documentation on rvm.
Please visit https://www.pivotaltracker.com/projects/26822 to see what is being worked on currently.

You received this message because you are subscribed to the Google
Groups "rvm (Ruby Version Manager)" group.
To post to this group, send email to rubyversionmanager-/***@public.gmane.org
To unsubscribe from this group, send email to
rubyversionmanager+unsubscribe-/***@public.gmane.org
For more options, visit this group at
http://groups.google.com/group/rubyversionmanager?hl=en
LightBe Corp
2012-12-13 18:55:33 UTC
Permalink
Thanks so much. I need to create an account. Where do I do that?
Post by mpapis
please talk to me(mpapis) here =>
http://webchat.freenode.net/?channels=rvm
there is a lot of small questions to ask it would be a lot faster this way
Post by LightBe Corp
I downloaded and installed the 3.0.18 gem from www.phusionpassenger.com.
I copied the license key passenger-enterprise-license file into /etc. I
assume that is what they meant by installing the license key in to /etc as
stated on the website. Then I did the
sudo passenger-install-apache2-module command.
I mean no harm but the first few sentences tell you what I did to
initially install this :)
Post by mpapis
sorry i missed it (it's know fact that to long text is not read at all -
this is why I try to cut the rvm texts)
as for the error how did you install *passenger-enterprise-server* -
what are the changes you did in /etc ?
Post by LightBe Corp
The last half of my post shows the error I got when I tried to use
rvmsudo. The information starts with the sentence right before the second
block of bold text which is the error.
Post by mpapis
you do not use sudo with RVM, make sure to use rvmsudo
Post by LightBe Corp
I just purchased a one year license a few minutes ago after upgrading
from Lion to Mountain Lion. I downloaded and installed the 3.0.18 gem. I
then installed the license key by copying the downloaded file into /etc as
stated. Afterwards I attempted to install the Apache version of 3.0.18 by
sudo passenger-install-apache2-module
*Checking for required software...*
*
*
* * GNU C++ compiler... found at /usr/bin/g++*
* * Curl development headers with SSL support... found*
* * OpenSSL development headers... found*
* * Zlib development headers... found*
* * Ruby development headers... found*
* * OpenSSL support for Ruby... found*
* * RubyGems... found*
*Your RVM wrapper scripts are too old. Please update them first by
running 'rvm get head && rvm reload && rvm repair all'.*
I executed the suggested commands two or three times but got the same
error. I did a web search and someone on Stack Overflow suggested that you
should do the first two commands mentioned in the Passenger output and then
do rvm get stable. I still get the error.
I thought I would try rvmsudo passenger-install-apache2-module. I
*/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:247:in
`to_specs': Could not find passenger-enterprise-server (>= 0) amongst
[actionmailer-3.2.9, actionpack-3.2.9, activemodel-3.2.9,
activerecord-3.2.9, activeresource-3.2.9, activesupport-3.2.9,
annotate-2.4.1.beta1, arel-3.0.2, builder-3.0.4, bundler-1.2.3,
capybara-1.1.2, childprocess-0.3.6, coderay-1.0.8, coffee-rails-3.2.2,
coffee-script-2.2.0, coffee-script-source-1.4.0, commonjs-0.2.6,
cucumber-1.2.1, cucumber-rails-1.2.1, daemons-1.1.9, diff-lcs-1.1.3,
erubis-2.7.0, eventmachine-1.0.0, execjs-1.4.0, ffi-1.2.0, gherkin-2.11.5,
growl-1.0.3, guard-1.5.4, guard-rspec-1.2.1, guard-spork-1.2.0, hike-1.2.1,
i18n-0.6.1, journey-1.0.4, jquery-rails-2.0.2, json-1.7.5, less-2.2.2,
less-rails-2.2.6, libv8-3.3.10.4-x86_64-darwin-12, libwebsocket-0.1.6.1,
listen-0.6.0, lumberjack-1.0.2, mail-2.4.4, metamagic-2.0.4,
method_source-0.8.1, mime-types-1.19, multi_json-1.5.0, multi_json-1.3.7,
nokogiri-1.5.5, polyglot-0.3.3, pry-0.9.10, rack-1.4.1, rack-cache-1.2,
rack-ssl-1.3.2, rack-test-0.6.2, rails-3.2.9, railties-3.2.9, rake-10.0.3,
rake-10.0.2, rb-fsevent-0.9.2, rdoc-3.12, rspec-2.11.0, rspec-core-2.11.1,
rspec-expectations-2.11.3, rspec-mocks-2.11.3, rspec-rails-2.11.0,
rubygems-bundler-1.1.0, rubyzip-0.9.9, rvm-1.11.3.5, sass-3.2.3,
sass-rails-3.2.5, selenium-webdriver-2.26.0, slop-3.3.3, spork-0.9.2,
sprockets-2.2.2, sprockets-2.2.1, sqlite3-1.3.6,
sys-proctable-0.9.2-universal-darwin, therubyracer-0.10.2, thin-1.5.0,
thor-0.16.0, tilt-1.3.3, treetop-1.4.12, twitter-bootstrap-rails-2.1.2,
tzinfo-0.3.35, uglifier-1.2.3, websocket-1.0.4, xpath-0.1.4]
(Gem::LoadError)*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:256:in
`to_spec'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems.rb:1231:in
`gem'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/bin/passenger-install-apache2-module:22:in
`<main>'*
I cannot find anything in the Passenger software for this problem.
What version of RVM should I use to get this working? From what I have
read I should not be seeing the error at all with newer versions of RVM. I
have three websites that I need to get working immediately. I cannot do
anything until this is resolved. I have not used RVM for much other than
installing Ruby at this point. Any help will be appreciated. Thanks!
--
Please visit http://rvm.io/ for documentation on rvm.
Please visit https://www.pivotaltracker.com/projects/26822 to see what is being worked on currently.

You received this message because you are subscribed to the Google
Groups "rvm (Ruby Version Manager)" group.
To post to this group, send email to rubyversionmanager-/***@public.gmane.org
To unsubscribe from this group, send email to
rubyversionmanager+unsubscribe-/***@public.gmane.org
For more options, visit this group at
http://groups.google.com/group/rubyversionmanager?hl=en
mpapis
2012-12-13 21:32:44 UTC
Permalink
http://freenode.net/faq.shtml#nicksetup
Post by LightBe Corp
Thanks so much. I need to create an account. Where do I do that?
Post by mpapis
please talk to me(mpapis) here =>
http://webchat.freenode.net/?channels=rvm
there is a lot of small questions to ask it would be a lot faster this way
Post by LightBe Corp
I downloaded and installed the 3.0.18 gem from www.phusionpassenger.com.
I copied the license key passenger-enterprise-license file into /etc. I
assume that is what they meant by installing the license key in to /etc as
stated on the website. Then I did the
sudo passenger-install-apache2-module command.
I mean no harm but the first few sentences tell you what I did to
initially install this :)
Post by mpapis
sorry i missed it (it's know fact that to long text is not read at all
- this is why I try to cut the rvm texts)
as for the error how did you install *passenger-enterprise-server* -
what are the changes you did in /etc ?
Post by LightBe Corp
The last half of my post shows the error I got when I tried to use
rvmsudo. The information starts with the sentence right before the second
block of bold text which is the error.
Post by mpapis
you do not use sudo with RVM, make sure to use rvmsudo
Post by LightBe Corp
I just purchased a one year license a few minutes ago after
upgrading from Lion to Mountain Lion. I downloaded and installed the
3.0.18 gem. I then installed the license key by copying the downloaded
file into /etc as stated. Afterwards I attempted to install the Apache
sudo passenger-install-apache2-module
*Checking for required software...*
*
*
* * GNU C++ compiler... found at /usr/bin/g++*
* * Curl development headers with SSL support... found*
* * OpenSSL development headers... found*
* * Zlib development headers... found*
* * Ruby development headers... found*
* * OpenSSL support for Ruby... found*
* * RubyGems... found*
*Your RVM wrapper scripts are too old. Please update them first by
running 'rvm get head && rvm reload && rvm repair all'.*
I executed the suggested commands two or three times but got the
same error. I did a web search and someone on Stack Overflow suggested
that you should do the first two commands mentioned in the Passenger output
and then do rvm get stable. I still get the error.
I thought I would try rvmsudo passenger-install-apache2-module. I
*/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:247:in
`to_specs': Could not find passenger-enterprise-server (>= 0) amongst
[actionmailer-3.2.9, actionpack-3.2.9, activemodel-3.2.9,
activerecord-3.2.9, activeresource-3.2.9, activesupport-3.2.9,
annotate-2.4.1.beta1, arel-3.0.2, builder-3.0.4, bundler-1.2.3,
capybara-1.1.2, childprocess-0.3.6, coderay-1.0.8, coffee-rails-3.2.2,
coffee-script-2.2.0, coffee-script-source-1.4.0, commonjs-0.2.6,
cucumber-1.2.1, cucumber-rails-1.2.1, daemons-1.1.9, diff-lcs-1.1.3,
erubis-2.7.0, eventmachine-1.0.0, execjs-1.4.0, ffi-1.2.0, gherkin-2.11.5,
growl-1.0.3, guard-1.5.4, guard-rspec-1.2.1, guard-spork-1.2.0, hike-1.2.1,
i18n-0.6.1, journey-1.0.4, jquery-rails-2.0.2, json-1.7.5, less-2.2.2,
less-rails-2.2.6, libv8-3.3.10.4-x86_64-darwin-12, libwebsocket-0.1.6.1,
listen-0.6.0, lumberjack-1.0.2, mail-2.4.4, metamagic-2.0.4,
method_source-0.8.1, mime-types-1.19, multi_json-1.5.0, multi_json-1.3.7,
nokogiri-1.5.5, polyglot-0.3.3, pry-0.9.10, rack-1.4.1, rack-cache-1.2,
rack-ssl-1.3.2, rack-test-0.6.2, rails-3.2.9, railties-3.2.9, rake-10.0.3,
rake-10.0.2, rb-fsevent-0.9.2, rdoc-3.12, rspec-2.11.0, rspec-core-2.11.1,
rspec-expectations-2.11.3, rspec-mocks-2.11.3, rspec-rails-2.11.0,
rubygems-bundler-1.1.0, rubyzip-0.9.9, rvm-1.11.3.5, sass-3.2.3,
sass-rails-3.2.5, selenium-webdriver-2.26.0, slop-3.3.3, spork-0.9.2,
sprockets-2.2.2, sprockets-2.2.1, sqlite3-1.3.6,
sys-proctable-0.9.2-universal-darwin, therubyracer-0.10.2, thin-1.5.0,
thor-0.16.0, tilt-1.3.3, treetop-1.4.12, twitter-bootstrap-rails-2.1.2,
tzinfo-0.3.35, uglifier-1.2.3, websocket-1.0.4, xpath-0.1.4]
(Gem::LoadError)*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:256:in
`to_spec'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems.rb:1231:in
`gem'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/bin/passenger-install-apache2-module:22:in
`<main>'*
I cannot find anything in the Passenger software for this problem.
What version of RVM should I use to get this working? From what I have
read I should not be seeing the error at all with newer versions of RVM. I
have three websites that I need to get working immediately. I cannot do
anything until this is resolved. I have not used RVM for much other than
installing Ruby at this point. Any help will be appreciated. Thanks!
--
Please visit http://rvm.io/ for documentation on rvm.
Please visit https://www.pivotaltracker.com/projects/26822 to see what is being worked on currently.

You received this message because you are subscribed to the Google
Groups "rvm (Ruby Version Manager)" group.
To post to this group, send email to rubyversionmanager-/***@public.gmane.org
To unsubscribe from this group, send email to
rubyversionmanager+unsubscribe-/***@public.gmane.org
For more options, visit this group at
http://groups.google.com/group/rubyversionmanager?hl=en
LightBe Corp
2012-12-13 21:56:34 UTC
Permalink
I am new to IRC and have no clue about what to do or where to go. Thanks
so much for offering your help. I read the link you provided but I do not
know where to request the nickname and password in step 2. Do I need to
install something on my end to get this working? Thanks for your patience.
Post by mpapis
http://freenode.net/faq.shtml#nicksetup
Post by LightBe Corp
Thanks so much. I need to create an account. Where do I do that?
Post by mpapis
please talk to me(mpapis) here =>
http://webchat.freenode.net/?channels=rvm
there is a lot of small questions to ask it would be a lot faster this way
Post by LightBe Corp
I downloaded and installed the 3.0.18 gem from www.phusionpassenger.com.
I copied the license key passenger-enterprise-license file into /etc. I
assume that is what they meant by installing the license key in to /etc as
stated on the website. Then I did the
sudo passenger-install-apache2-module command.
I mean no harm but the first few sentences tell you what I did to
initially install this :)
Post by mpapis
sorry i missed it (it's know fact that to long text is not read at all
- this is why I try to cut the rvm texts)
as for the error how did you install *passenger-enterprise-server* -
what are the changes you did in /etc ?
Post by LightBe Corp
The last half of my post shows the error I got when I tried to use
rvmsudo. The information starts with the sentence right before the second
block of bold text which is the error.
Post by mpapis
you do not use sudo with RVM, make sure to use rvmsudo
Post by LightBe Corp
I just purchased a one year license a few minutes ago after
upgrading from Lion to Mountain Lion. I downloaded and installed the
3.0.18 gem. I then installed the license key by copying the downloaded
file into /etc as stated. Afterwards I attempted to install the Apache
sudo passenger-install-apache2-module
*Checking for required software...*
*
*
* * GNU C++ compiler... found at /usr/bin/g++*
* * Curl development headers with SSL support... found*
* * OpenSSL development headers... found*
* * Zlib development headers... found*
* * Ruby development headers... found*
* * OpenSSL support for Ruby... found*
* * RubyGems... found*
*Your RVM wrapper scripts are too old. Please update them first by
running 'rvm get head && rvm reload && rvm repair all'.*
I executed the suggested commands two or three times but got the
same error. I did a web search and someone on Stack Overflow suggested
that you should do the first two commands mentioned in the Passenger output
and then do rvm get stable. I still get the error.
I thought I would try rvmsudo passenger-install-apache2-module. I
*/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:247:in
`to_specs': Could not find passenger-enterprise-server (>= 0) amongst
[actionmailer-3.2.9, actionpack-3.2.9, activemodel-3.2.9,
activerecord-3.2.9, activeresource-3.2.9, activesupport-3.2.9,
annotate-2.4.1.beta1, arel-3.0.2, builder-3.0.4, bundler-1.2.3,
capybara-1.1.2, childprocess-0.3.6, coderay-1.0.8, coffee-rails-3.2.2,
coffee-script-2.2.0, coffee-script-source-1.4.0, commonjs-0.2.6,
cucumber-1.2.1, cucumber-rails-1.2.1, daemons-1.1.9, diff-lcs-1.1.3,
erubis-2.7.0, eventmachine-1.0.0, execjs-1.4.0, ffi-1.2.0, gherkin-2.11.5,
growl-1.0.3, guard-1.5.4, guard-rspec-1.2.1, guard-spork-1.2.0, hike-1.2.1,
i18n-0.6.1, journey-1.0.4, jquery-rails-2.0.2, json-1.7.5, less-2.2.2,
less-rails-2.2.6, libv8-3.3.10.4-x86_64-darwin-12, libwebsocket-0.1.6.1,
listen-0.6.0, lumberjack-1.0.2, mail-2.4.4, metamagic-2.0.4,
method_source-0.8.1, mime-types-1.19, multi_json-1.5.0, multi_json-1.3.7,
nokogiri-1.5.5, polyglot-0.3.3, pry-0.9.10, rack-1.4.1, rack-cache-1.2,
rack-ssl-1.3.2, rack-test-0.6.2, rails-3.2.9, railties-3.2.9, rake-10.0.3,
rake-10.0.2, rb-fsevent-0.9.2, rdoc-3.12, rspec-2.11.0, rspec-core-2.11.1,
rspec-expectations-2.11.3, rspec-mocks-2.11.3, rspec-rails-2.11.0,
rubygems-bundler-1.1.0, rubyzip-0.9.9, rvm-1.11.3.5, sass-3.2.3,
sass-rails-3.2.5, selenium-webdriver-2.26.0, slop-3.3.3, spork-0.9.2,
sprockets-2.2.2, sprockets-2.2.1, sqlite3-1.3.6,
sys-proctable-0.9.2-universal-darwin, therubyracer-0.10.2, thin-1.5.0,
thor-0.16.0, tilt-1.3.3, treetop-1.4.12, twitter-bootstrap-rails-2.1.2,
tzinfo-0.3.35, uglifier-1.2.3, websocket-1.0.4, xpath-0.1.4]
(Gem::LoadError)*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:256:in
`to_spec'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems.rb:1231:in
`gem'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/bin/passenger-install-apache2-module:22:in
`<main>'*
I cannot find anything in the Passenger software for this problem.
What version of RVM should I use to get this working? From what I have
read I should not be seeing the error at all with newer versions of RVM. I
have three websites that I need to get working immediately. I cannot do
anything until this is resolved. I have not used RVM for much other than
installing Ruby at this point. Any help will be appreciated. Thanks!
--
Please visit http://rvm.io/ for documentation on rvm.
Please visit https://www.pivotaltracker.com/projects/26822 to see what is being worked on currently.

You received this message because you are subscribed to the Google
Groups "rvm (Ruby Version Manager)" group.
To post to this group, send email to rubyversionmanager-/***@public.gmane.org
To unsubscribe from this group, send email to
rubyversionmanager+unsubscribe-/***@public.gmane.org
For more options, visit this group at
http://groups.google.com/group/rubyversionmanager?hl=en
mpapis
2012-12-14 05:58:54 UTC
Permalink
maybe try something else, open an ticket here
https://github.com/wayneeseguin/rvm/issues - please include all the details
mentioned here so far
Post by LightBe Corp
I am new to IRC and have no clue about what to do or where to go. Thanks
so much for offering your help. I read the link you provided but I do not
know where to request the nickname and password in step 2. Do I need to
install something on my end to get this working? Thanks for your patience.
Post by mpapis
http://freenode.net/faq.shtml#nicksetup
Post by LightBe Corp
Thanks so much. I need to create an account. Where do I do that?
Post by mpapis
please talk to me(mpapis) here =>
http://webchat.freenode.net/?channels=rvm
there is a lot of small questions to ask it would be a lot faster this way
Post by LightBe Corp
I downloaded and installed the 3.0.18 gem from
www.phusionpassenger.com. I copied the license key
passenger-enterprise-license file into /etc. I assume that is what they
meant by installing the license key in to /etc as stated on the website.
Then I did the sudo passenger-install-apache2-module command.
I mean no harm but the first few sentences tell you what I did to
initially install this :)
Post by mpapis
sorry i missed it (it's know fact that to long text is not read at
all - this is why I try to cut the rvm texts)
as for the error how did you install *passenger-enterprise-server* -
what are the changes you did in /etc ?
Post by LightBe Corp
The last half of my post shows the error I got when I tried to use
rvmsudo. The information starts with the sentence right before the second
block of bold text which is the error.
Post by mpapis
you do not use sudo with RVM, make sure to use rvmsudo
Post by LightBe Corp
I just purchased a one year license a few minutes ago after
upgrading from Lion to Mountain Lion. I downloaded and installed the
3.0.18 gem. I then installed the license key by copying the downloaded
file into /etc as stated. Afterwards I attempted to install the Apache
sudo passenger-install-apache2-module
*Checking for required software...*
*
*
* * GNU C++ compiler... found at /usr/bin/g++*
* * Curl development headers with SSL support... found*
* * OpenSSL development headers... found*
* * Zlib development headers... found*
* * Ruby development headers... found*
* * OpenSSL support for Ruby... found*
* * RubyGems... found*
*Your RVM wrapper scripts are too old. Please update them first
by running 'rvm get head && rvm reload && rvm repair all'.*
I executed the suggested commands two or three times but got the
same error. I did a web search and someone on Stack Overflow suggested
that you should do the first two commands mentioned in the Passenger output
and then do rvm get stable. I still get the error.
I thought I would try rvmsudo passenger-install-apache2-module. I
*/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:247:in
`to_specs': Could not find passenger-enterprise-server (>= 0) amongst
[actionmailer-3.2.9, actionpack-3.2.9, activemodel-3.2.9,
activerecord-3.2.9, activeresource-3.2.9, activesupport-3.2.9,
annotate-2.4.1.beta1, arel-3.0.2, builder-3.0.4, bundler-1.2.3,
capybara-1.1.2, childprocess-0.3.6, coderay-1.0.8, coffee-rails-3.2.2,
coffee-script-2.2.0, coffee-script-source-1.4.0, commonjs-0.2.6,
cucumber-1.2.1, cucumber-rails-1.2.1, daemons-1.1.9, diff-lcs-1.1.3,
erubis-2.7.0, eventmachine-1.0.0, execjs-1.4.0, ffi-1.2.0, gherkin-2.11.5,
growl-1.0.3, guard-1.5.4, guard-rspec-1.2.1, guard-spork-1.2.0, hike-1.2.1,
i18n-0.6.1, journey-1.0.4, jquery-rails-2.0.2, json-1.7.5, less-2.2.2,
less-rails-2.2.6, libv8-3.3.10.4-x86_64-darwin-12, libwebsocket-0.1.6.1,
listen-0.6.0, lumberjack-1.0.2, mail-2.4.4, metamagic-2.0.4,
method_source-0.8.1, mime-types-1.19, multi_json-1.5.0, multi_json-1.3.7,
nokogiri-1.5.5, polyglot-0.3.3, pry-0.9.10, rack-1.4.1, rack-cache-1.2,
rack-ssl-1.3.2, rack-test-0.6.2, rails-3.2.9, railties-3.2.9, rake-10.0.3,
rake-10.0.2, rb-fsevent-0.9.2, rdoc-3.12, rspec-2.11.0, rspec-core-2.11.1,
rspec-expectations-2.11.3, rspec-mocks-2.11.3, rspec-rails-2.11.0,
rubygems-bundler-1.1.0, rubyzip-0.9.9, rvm-1.11.3.5, sass-3.2.3,
sass-rails-3.2.5, selenium-webdriver-2.26.0, slop-3.3.3, spork-0.9.2,
sprockets-2.2.2, sprockets-2.2.1, sqlite3-1.3.6,
sys-proctable-0.9.2-universal-darwin, therubyracer-0.10.2, thin-1.5.0,
thor-0.16.0, tilt-1.3.3, treetop-1.4.12, twitter-bootstrap-rails-2.1.2,
tzinfo-0.3.35, uglifier-1.2.3, websocket-1.0.4, xpath-0.1.4]
(Gem::LoadError)*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:256:in
`to_spec'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems.rb:1231:in
`gem'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/bin/passenger-install-apache2-module:22:in
`<main>'*
I cannot find anything in the Passenger software for this problem.
What version of RVM should I use to get this working? From what I have
read I should not be seeing the error at all with newer versions of RVM. I
have three websites that I need to get working immediately. I cannot do
anything until this is resolved. I have not used RVM for much other than
installing Ruby at this point. Any help will be appreciated. Thanks!
--
Please visit http://rvm.io/ for documentation on rvm.
Please visit https://www.pivotaltracker.com/projects/26822 to see what is being worked on currently.

You received this message because you are subscribed to the Google
Groups "rvm (Ruby Version Manager)" group.
To post to this group, send email to rubyversionmanager-/***@public.gmane.org
To unsubscribe from this group, send email to
rubyversionmanager+unsubscribe-/***@public.gmane.org
For more options, visit this group at
http://groups.google.com/group/rubyversionmanager?hl=en
LightBe Corp
2012-12-14 11:56:10 UTC
Permalink
I just submitted my ticket with images of the messages I get. I will do
more web searches while this ticket is being reviewed. Hopefully I can get
this resolved today. One of my sites needs to be up for a live broadcast
on Saturday evening. Thanks so much for your help.
Post by mpapis
maybe try something else, open an ticket here
https://github.com/wayneeseguin/rvm/issues - please include all the
details mentioned here so far
Post by LightBe Corp
I am new to IRC and have no clue about what to do or where to go. Thanks
so much for offering your help. I read the link you provided but I do not
know where to request the nickname and password in step 2. Do I need to
install something on my end to get this working? Thanks for your patience.
Post by mpapis
http://freenode.net/faq.shtml#nicksetup
Post by LightBe Corp
Thanks so much. I need to create an account. Where do I do that?
Post by mpapis
please talk to me(mpapis) here =>
http://webchat.freenode.net/?channels=rvm
there is a lot of small questions to ask it would be a lot faster this way
Post by LightBe Corp
I downloaded and installed the 3.0.18 gem from
www.phusionpassenger.com. I copied the license key
passenger-enterprise-license file into /etc. I assume that is what they
meant by installing the license key in to /etc as stated on the website.
Then I did the sudo passenger-install-apache2-module command.
I mean no harm but the first few sentences tell you what I did to
initially install this :)
Post by mpapis
sorry i missed it (it's know fact that to long text is not read at
all - this is why I try to cut the rvm texts)
as for the error how did you install *passenger-enterprise-server*- what are the changes you did in /etc ?
Post by LightBe Corp
The last half of my post shows the error I got when I tried to use
rvmsudo. The information starts with the sentence right before the second
block of bold text which is the error.
Post by mpapis
you do not use sudo with RVM, make sure to use rvmsudo
Post by LightBe Corp
I just purchased a one year license a few minutes ago after
upgrading from Lion to Mountain Lion. I downloaded and installed the
3.0.18 gem. I then installed the license key by copying the downloaded
file into /etc as stated. Afterwards I attempted to install the Apache
sudo passenger-install-apache2-module
*Checking for required software...*
*
*
* * GNU C++ compiler... found at /usr/bin/g++*
* * Curl development headers with SSL support... found*
* * OpenSSL development headers... found*
* * Zlib development headers... found*
* * Ruby development headers... found*
* * OpenSSL support for Ruby... found*
* * RubyGems... found*
*Your RVM wrapper scripts are too old. Please update them first
by running 'rvm get head && rvm reload && rvm repair all'.*
I executed the suggested commands two or three times but got the
same error. I did a web search and someone on Stack Overflow suggested
that you should do the first two commands mentioned in the Passenger output
and then do rvm get stable. I still get the error.
I thought I would try rvmsudo passenger-install-apache2-module.
*/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:247:in
`to_specs': Could not find passenger-enterprise-server (>= 0) amongst
[actionmailer-3.2.9, actionpack-3.2.9, activemodel-3.2.9,
activerecord-3.2.9, activeresource-3.2.9, activesupport-3.2.9,
annotate-2.4.1.beta1, arel-3.0.2, builder-3.0.4, bundler-1.2.3,
capybara-1.1.2, childprocess-0.3.6, coderay-1.0.8, coffee-rails-3.2.2,
coffee-script-2.2.0, coffee-script-source-1.4.0, commonjs-0.2.6,
cucumber-1.2.1, cucumber-rails-1.2.1, daemons-1.1.9, diff-lcs-1.1.3,
erubis-2.7.0, eventmachine-1.0.0, execjs-1.4.0, ffi-1.2.0, gherkin-2.11.5,
growl-1.0.3, guard-1.5.4, guard-rspec-1.2.1, guard-spork-1.2.0, hike-1.2.1,
i18n-0.6.1, journey-1.0.4, jquery-rails-2.0.2, json-1.7.5, less-2.2.2,
less-rails-2.2.6, libv8-3.3.10.4-x86_64-darwin-12, libwebsocket-0.1.6.1,
listen-0.6.0, lumberjack-1.0.2, mail-2.4.4, metamagic-2.0.4,
method_source-0.8.1, mime-types-1.19, multi_json-1.5.0, multi_json-1.3.7,
nokogiri-1.5.5, polyglot-0.3.3, pry-0.9.10, rack-1.4.1, rack-cache-1.2,
rack-ssl-1.3.2, rack-test-0.6.2, rails-3.2.9, railties-3.2.9, rake-10.0.3,
rake-10.0.2, rb-fsevent-0.9.2, rdoc-3.12, rspec-2.11.0, rspec-core-2.11.1,
rspec-expectations-2.11.3, rspec-mocks-2.11.3, rspec-rails-2.11.0,
rubygems-bundler-1.1.0, rubyzip-0.9.9, rvm-1.11.3.5, sass-3.2.3,
sass-rails-3.2.5, selenium-webdriver-2.26.0, slop-3.3.3, spork-0.9.2,
sprockets-2.2.2, sprockets-2.2.1, sqlite3-1.3.6,
sys-proctable-0.9.2-universal-darwin, therubyracer-0.10.2, thin-1.5.0,
thor-0.16.0, tilt-1.3.3, treetop-1.4.12, twitter-bootstrap-rails-2.1.2,
tzinfo-0.3.35, uglifier-1.2.3, websocket-1.0.4, xpath-0.1.4]
(Gem::LoadError)*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems/dependency.rb:256:in
`to_spec'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/rubygems.rb:1231:in
`gem'*
* from
/Users/server1/.rvm/rubies/ruby-1.9.3-p327/bin/passenger-install-apache2-module:22:in
`<main>'*
I cannot find anything in the Passenger software for this
problem. What version of RVM should I use to get this working? From what
I have read I should not be seeing the error at all with newer versions of
RVM. I have three websites that I need to get working immediately. I
cannot do anything until this is resolved. I have not used RVM for much
other than installing Ruby at this point. Any help will be appreciated.
Thanks!
--
Please visit http://rvm.io/ for documentation on rvm.
Please visit https://www.pivotaltracker.com/projects/26822 to see what is being worked on currently.

You received this message because you are subscribed to the Google
Groups "rvm (Ruby Version Manager)" group.
To post to this group, send email to rubyversionmanager-/***@public.gmane.org
To unsubscribe from this group, send email to
rubyversionmanager+unsubscribe-/***@public.gmane.org
For more options, visit this group at
http://groups.google.com/group/rubyversionmanager?hl=en
Loading...